OpenCart 2.0 Released

19 October 2014,

OpenCart 2.0 has been released after a long time in the development stage.

OpenCart 2 is expected to bring the Open Source e-commerce platform to new a level compatible with today's web browsing habits. The new version comes with tons of improvements and new features. The code base is much better, cleaner. The intuitive dashboard will make site maintenance much easier and many other great things. In this article, we will list the best new features of Opencart version 2.0.

Fully responsive design WITH Bootstrap 3 integration

bootstrap-opencart

The most expected new feature of Opencart 2.0 is the Integration of Bootstrap in the core files.
This means now Opencart is fully responsive. The BootStrap integration is immediately obvious to anyone familiar with the CSS framework

 

resp

The homepage is at once entirely familiar as well as fresh and updated.
Now your store becomes responsive and viewable on both desktop and mobile devices.

 

Font awesome support

font-awesome

Now you can take advantage of 400+ icons called Font Awesome  the Advanced CSS font collection . Just add the icon class and you got the cool icon displayed in your site.

 

OCmod - virtual file modification

The feature allows you to make modification of your website without changing the core files. No more separate installation required as OCmod is integrated at core of Opencart 2. The feature is to prevent the loss of user’s customization when upgrading.

 

Brand New Dashboard

dashboard

The new administration dashboard helps you focus on what is important: sales analytics, online customers. It’s also more friendly and easier to interact with your system.
The horizontal menu is now replaced with a left side vertical one for a smart navigation.

 

Extension Installer

ext-installer

OpenCart 2.0 makes theme and extension installation much easier with the built-in Extension installer.
No more overwriting files via FTP, this brings you to the faster and more accurate installation process.
After uploading theme/extension, you will see list of files that will be overwritten when you proceed with the installation.

More payment gateways included by default

OpenCart version 1.x already support 20+ payment gateways, in the new version of OpenCart, a lot of payment gateways are added at core, the total payment gateways it supports now is 30+

  • Amazon Payments
  • BluePay Redirect (Requires SSL)
  • First Data EMEA Connect (3DSecure enabled)
  • First Data EMEA Web Service API
  • Free Checkout
  • NOCHEX
  • Payza
  • PayPal Pro iFrame
  • Web Payment Software
  • Secure Trading Web Service

Event notification system

notification


The Event Notification system shows a notification when an action take places with event function.

The Notification includes:

  • How many orders are in which status ?
  • How many new customers are waiting for approval ?
  • How many products are out of stock ?
  • How many reviews are pending ?

API integrated

The API is to integrate your site to third party extension (3rd extension) platform. For example, creating iOS and Android application of the website or connect the data to a CMS website.

 

MaxMind Fraud Detection System for Security

fraud-maxmind

Opencart 2.0 comes with MaxMind Fraud Detection System integrated by default. MaxMind is a service which identifying risky orders to be held for further review. It detects the fraud orders based on the high risk IP address, high risk email, high risk device, or anonymizing proxy.

If you want to use this Just register at MaxMind and paste the key in the Fraud Tab inside your Opencart 2  System settings panel.

A warning for all  store owners:

It is not advisable to upgrade your store just yet. I'd advise you to download and test the new version by all means.
With Opencart 2.0 only just being released there will still be bugs and code issues to be found and worked out by the community, so best practice is to not upgrade for a few months yet but prepare for when you think the time is right.
Also look for compatible versions of your themes and modules before upgrading.
As of yet, there is no officially supported script for automatically updating from 1.5.x to 2.0 so only attempt it if you know what you’re doing as there are reports of many things going wrong with upgrades!

Login to post comments

Get The Latest Browsers

firefoxLogo

google

News Letter

Sign up for news letter